Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar si celda contiene un texto

En este ejemplo observaremos como sumar solo si la celda contiene un texto que hayamos definido previamente, observemos que en el cuadro encontramos la venta de algunos productos y nos interesa identificar solo algunos de ellos.

En el ejemplo nos interesa incluir en la suma solo aquellos productos que contienen el texto “apa” como parte de la descripción.

Fórmula para Sumar si celda contiene un texto

Como podemos observar en la celda G5 se utiliza la siguiente fórmula:

=SUMAR.SI(C4:C11,"*apa*",D4:D11)

El primer parámetro de la función SUMAR.SI, contiene la relación de celdas que deben cumplir una determinada condición, la condición referida se encuentra en el segundo parámetro y sirve para identificar cuales de las celdas del primer parámetro contienen el texto “apa”, notemos que este texto hace uso de asteriscos al inicio y al final, eso sirve para representar la existencia de cero, uno o mas caracteres, de esta forma, el texto “apa” puede encontrarse al incio, al final o como parte de todo el texto.

Finalmente, el tercer parámetro en la fórmula empleada sirve indicar donde se encuentran los montos que formarán parte de la sumatoria, naturalmente, no todos los indicados en este rango de celdas formarán parte de la suma, sino solo aquellos que se encuentren en la misma fila de los que cumplen con la condición de contar con el texto “apa”.

6 Comments

  1. Excelente información. Me ha resultado muy útil.
    Dos consultas, siguiendo con el ejemplo del calzado:
    1-. ¿Como se puede hacer una suma con una segunda condición?, por ejemplo, que sume las celdas si en la descripción del producto aparece, además de “app”, el número 3.

    2-. ¿Se puede poner en una formula, que haga referencia a otra celda, la condición o criterio “*apa*”?
    En el ejemplo, poner en la celda F1: “apa” y en la fórmula =SUMAR.SI(C4:C11,”*apa*”,D4:D11) reemplazar “*apa*” por una formula que haga referencia a la celda F1.

    Gracias

    Saludos cordiales

  2. Muchísimas gracias Javier por tus aportes, me han resultado de gran ayuda.

  3. quiero hacer una sumatoria, pero que busque varios textos de contenido, es decir ” * ” ó ” * ” ó ” * “, etc

  4. SE PUEDE AGREGAR UNA CONDICIÓN POR FECHA ? TENGO UNA BASE DE DATOS CON LA FORMA QUE PONES ME FACILITA MUCHO PERO ME FALTARÍA PONERLE LA RESTRICCIÓN CON FECHA

  5. ¿En SUMAR.SI en vez de un texto como “criterio”, se puede poner el valor de una celda?

    He probado esto y no funciona

    =SUMAR.SI(C1:C1000;”A9″;E1:E1000)

    Siendo A1 a A1000 listado de codigos de producto (p.e 04.01.01)

    C1 a C1000 donde se han introducido los codigos de producto; y el precio vendido en cada operacion en E1 a E1000

    Para sacar un sumatorio del importe total (columna E) de cada código (columna C)

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5