Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas que contengan texto

En el siguiente ejemplo examinemos como contar celdas que contengan texto, cualquier texto, o algún texto en Excel, la idea es contar celdas con texto, excluyendo los números, para ello emplearemos la función CONTAR.SI, veamos el ejemplo:

Contar celdas que contengan texto, Contar celdas que contengan texto

Fórmula para contar celdas que contengan texto

Como podemos observar en el ejemplo, en la celda E5 encontramos:

=CONTAR.SI(B3:B12,"*Z*")

El asterisco nos sirve para identificar la existencia de uno o más caracteres, es decir se contarán todas celdas que contengan una zeta "Z" (sin importar si es mayúscula o minúscula)  dentro de la relación de celdas, antes o después de la zeta pueden existir cero o mas caracteres, el resultado obtenido es 3 debido a que al contar solo se consideran las celdas  B7, B8 y B9.

En la celda E6 encontraremos:

=CONTAR.SI(B3:B12,"*1*")

Notemos que este es un caso especial, ya que al contar solo se tomará en cuenta las celdas B7, B8 y B9, no se incluirá B12 ya que B12 es un número (no es un texto) y por lo tanto no forma parte del conteo.

 

Fórmula para contar celdas con texto

En el caso anterior se realizó el conteo tomando en consideración la búsqueda de algún texto en particular, en el siguiente caso observaremos como encontrar todas las celdas con texto (cualquier texto) , y también identificaremos la cantidad de celdas que no contengan texto.

 

contar celdas con texto, Contar celdas que contengan texto

Como podemos ver en la celda E3, la fórmula es:

=CONTAR.SI(B3:B8,"*")

La cual nos retorna 2, por que solo considera las celdas B3 y B4, es decir se ignoran las celdas con números, errores, celdas vacías, y también se ignoran los valores lógicos (VERDADERO y FALSO).

También podemos usar la fórmula SUMAPRODUCTO para contar con los valores de texto junto con la función ESTEXTO:

 

=SUMAPRODUCTO(--ESTEXTO(B3:B8))

En esta fórmula el doble guión ayuda a emplear el resultado de ESTEXTO, cambiando el valor lógico obtenido por ceros y unos para que la fórmula SUMAPRODUCTO nos pueda retornar 2.

Fórmula para contar celdas que no contienen texto

En el ejemplo anterior, en la celda E4 encontraremos:

=CONTAR.SI(B3:B8,"<>*")

Esta fórmula empleamos el operador distinto ("<>") lo cual nos permite es identificar todas las celdas que no contengan textos, es decir se excluyen las celdas B3 y B4, todas las demás celdas forman son contadas.

Al igual que en los casos iniciales podríamos emplear reemplazar el "<>*" por algo como "<>*Z" , con esta modificación estaríamos contando las celdas que no contengan una "Z" como parte del texto.

 

5 comentarios

  1. Buenas tardes, me gustaría saber como puedo hacer para sumar celdas cuyo contenido es el Nombre y el Apellido de una persona pero específicamente necesitaría sumar las celdas cuyos nombres terminen en "X letra"

    Ejemplo:
    Total de Unidades de los vendedores cuya segunda letra del nombre sea la letra O

  2. Hola, buenas tardes. Me ha encantado el contenido de su página, pero ando buscando algo que no encuentro. El desafio es que necesito contar dentro de una misma celda cuantos veces se repiten los numeros y que me coloque el conteo donde corresponda.
    Si la cifra es 101 que me especifique en la casilla 1 un dos, como que se repite dos veces y en la casilla 0 un 1, como que hay uno....gracias

  3. Hola! Mi pregunta es: COmo puedo contar palabras en distintos rangos, no estan todos en la misma fila, sinó que tengo que contar las veces que sale una palabra en la misma tabla

  4. Hola, y Felicidades por la utilidad de su página.
    Cómo podría en esta fórmula (=CONTAR.SI(B3:B12,"*Z*"), substituir el caracter "Z", por una referencia???...En su ejemplo la referencia sería D5.

    Necesito contar Nombres y apellidos que lo mismo están solos en una celda, que junto a otros nombres en otras celdas.

    Gracias.

  5. Hola

    ¿Cómo cuento celdas con valores lógicos Verdadero/Falso?

    CONTAR.SI no los cuenta

Deja un comentario

Los campos requeridos estan marcados con *.