Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar si celda contiene un texto

En este ejemplo observaremos como sumar solo si la celda contiene un texto que hayamos definido previamente, observemos que en el cuadro encontramos la venta de algunos productos y nos interesa identificar solo algunos de ellos.

Sumar si celda contiene un texto Sumar si celda contiene un texto

En el ejemplo nos interesa incluir en la suma solo aquellos productos que contienen el texto "apa" como parte de la descripción.

Fórmula para Sumar si celda contiene un texto

Como podemos observar en la celda G5 se utiliza la siguiente fórmula:

=SUMAR.SI(C4:C11,"*apa*",D4:D11)

El primer parámetro de la función SUMAR.SI, contiene la relación de celdas que deben cumplir una determinada condición, la condición referida se encuentra en el segundo parámetro y sirve para identificar cuales de las celdas del primer parámetro contienen el texto "apa", notemos que este texto hace uso de asteriscos al inicio y al final, eso sirve para representar la existencia de cero, uno o mas caracteres, de esta forma, el texto "apa" puede encontrarse al incio, al final o como parte de todo el texto.

Finalmente, el tercer parámetro en la fórmula empleada sirve indicar donde se encuentran los montos que formarán parte de la sumatoria, naturalmente, no todos los indicados en este rango de celdas formarán parte de la suma, sino solo aquellos que se encuentren en la misma fila de los que cumplen con la condición de contar con el texto "apa".

51 comentarios

  1. Cordial Saludo. Te agradezco por tanta información de valor que nos brindas. En esta oportunidad quiero hacer te una consulta.
    Resulta que tengo una celda con lista desplegable que tiene la opción en letras que dice SUMA o RESTA y en las siguientes dos celdas tengo la opción de introducir números.

    Necesito realizar la operación que se asigne en la lista desplegable y que me muestre el resultado en otra celda. ya sea suma o resta.

    Agradezco a su ayuda a ti o alguien en el foro

  2. Alguien sabe como descriminar "no contiene" un cierto un cierto texto para la formula CONTAR.SI.CONJUNTO. Es decir, cunado queremos filtrar celdas que "contienen" ciertas letras se pone "*xxx*", pero ¿Cómo seria cuando quiere filtrar no contiene?

  3. Buenos días, necesito sumar varias celdas con un mismo texto pero que se encuentran en columnas diferentes, de esta manera que explicáis no se puede. como seria?? Gracias.

  4. Hola, y como seria para que sume aquello que no contenga, en tu ejemplo "apa" que de por resultado 1300

  5. local_01/05/2020_tercer celda

    me pueden orientar por favor, quiero poner en donde dice tercer celda sumarle 1 dia mas si donde dice local, aparace asi.

    gracias.

    tengo la idea pero no la estoy ejecuantndo bien, ya que me marca error.

  6. Hola a todo el mundo. He intentado durante días y días buscar algo que parece muy simple a la hora de utilizar la función SUMAR.SI, pero no lo encuentro:
    Utilizando la tabla del ejemplo y la fórmula =SUMAR.SI(C4:C11,"*apa*",D4:D11), lo que necesito es que la condición, en vez de ser "apa", sea en todo momento el valor de texto que elija de una lista desplegable que he creado.
    Si por ejemplo escribo la fórmula tal que así =SUMAR.SI(C4:C11,K10,D4:D11) -- dónde K10 es la celda que contiene una lista desplegable con nombres, como ya expliqué -- el resultado es 0. Supongo que da 0 porque el contenido de la celda K10 no es un número sino un texto.
    Muchas gracias!

  7. Hola necesito una fórmula que me sume las celdas que digan una palabra determinada. Se puede hacer? Gracias

  8. TENGO LA SIGUIENTE FORMULA, PERO EN LUGAR DE TRAER UN VALOR NUMÉRICO QUIERO TRAER EL TEXTO QUE PUEDA EXISTIR, QUE DEBO MODIFICAR?

    =SUMAR.SI([PreciosOK.xlsx]Detalle!$E$6:$E$2361;B5;[PreciosOK.xlsx]Detalle!$R$6:$R$2361)

  9. Tengo varias sumarias en excel 2019 y de la noche a la mañana ahora me aparecen ¿#Nombre?, entro a cada formula y le doy enter y funciona, pero esto me lo hizo en todo el libro y es muy laborioso entrar a cada celda, alguien sabe que opcion se activo o como solucionarlo?

    Gracias.

  10. Hola, lo que yo quiero hacer es que con la función de formato condicional me resalte las celdas que tienen las palabras (por ejemplo): "silla, mesa, escritorio, mueble" de color azul y las celdas que tienen "arbol, manzana, pera, fruta" me las resalte de en verde.

    Más o menos esa es la idea.

    He visto que la mayoría sugieren hacer una nueva regla y luego darle a la opción que dice "aplicar unicamente a las celdas que contengan" y así... pero esto no me funcionó porque sólo me deja escribir una palabra: así que (continuando con el ejemplo) me resalta "silla" en color azul; pero no me deja resaltar las otras.

    Agradezco si me ayudan.

  11. muchas gracias por el aporte, sirvió de mucho

  12. EN ESTE CASO, SI QUIERO OBTENER EL IMPORTE DE CADA "TEXTO" POR FECHA CUAL SERIA LA FORMULA?

  13. Muchísimas gracias... estaba bloqueada y no daba con la clave, en este caso, con la fórmula...jajaja
    Muy bien explicado y sencillo.
    Os añado a marcadores para cualquier otra duda.

    Saludos.

  14. Mi consulta es: si tengo en una columna varios de estos datos del 1 al 10
    1(Uno)
    2(Dos)
    5(Cinco)
    7(Siete)....
    Quiero hacer que me diga cuantas veces se repite cada uno de ellos y que ademas me los sume, por ejemplo si el "1(uno)" aparece 2 veces y el "2(dos)" tres veces, quero que el resultado sea 5, con uno solo lo he probado:
    =CONTAR.SI(G13:H23;"*Un*") y me dá lo que no me sale es como sumarle el otro elemento, les agradezco ayuda..

  15. Buenas tardes

    Se puede hacer una fórmula en el que en la celda aparece determinado texto me lo multiplique por cierta cantidad o si tiene otro texto una cantidad diferente?

Página de comentarios 2 de 2
1 2

Deja una respuesta

Los campos requeridos estan marcados con *.