Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar por días

En el siguiente ejemplo veremos como se puede realizar una suma por días en Excel, el objetivo en este ejemplo consiste en sumar todos los montos correspondientes a cada día de la semana independientemente de la semana en que se encuentren.

Sumar por d%c3%adas, Sumar por días

Fórmula para Sumar por días

La fórmula empleada en H5 es la siguiente:

=SUMAPRODUCTO((DIASEM($B$4:$B$11,2)=G5)*$D$4:$D$11)

La función DIASEM tiene como finalidad identificar para elemento que se encuentre en  B4:B11 el día de la semana en función del segundo parámetro, que tiene como valor 2 para señalar que se considerará que la semana empieza en lunes y termina en domingo.

Luego al comparar el resultado de DIASEM con el valor de G5 se tendrá identificado por medio de VERDADERO aquellas fechas que correspondan al día Martes, y en el resto de días se tendrá FALSO, luego estos valores son multiplicados por los valores correspondientes a los montos, de esta forma solo se tomarán los montos correspondientes a los días martes.

Finalmente por medio de la función SUMAPRODUCTO se obtiene suma de todos los valores obtenidos previamente.

 

2 comentarios

  1. HOLA, COMO PUEDO SUMAR CANTIDADES POR FECHA ESPECIFICA… COLUMNA A: TODOS LOS DIAS DEL MES, COLUMNA B: TODOS LOS PAGOS REALIZADOS EN EL TRANSCURSO DE MES…. COLUMNA C: PAGOS TOTALES POR CADA UNO DE LOS DIAS.

  2. Hola buenas noches, como esta me gustaria saber si hay alguna forma se realizar calculos con la condicion del dia, pongo por ejemplo donde trabajo que una empresa de paqueteria….yo llevo un control diario y una hoja de excel semanal…. la idea de es crear algo que me saque la cuenta diaria pero con la condicion fecha ya que como comente anteriormente es una hoja semanal donde se juntan todas las fechas… la idea es que el sistema me hagas la sumatoria diario y me de resultados de separados de pagos hechos por punto, pagos realizados por transferencia, pagos realizados en efectivo, pagos realizados por pago movil …. la cosa es que esos totales me los tiene que dar de lunes a viernes…es decir diario por separado, me debe sacar los datos de la tabla tomando en cuenta el factor fecha…. no se si me logro explicar bien…. si me puedes ayudar o orientar de verdad que muchas GRACIAS. soy nuevo en excel y sobre todo en vba que creo que seria lo ideal para esto… en si tendre diario 4 resultado donde la primera condicion es el dia, su fecha…. es decir, condicion1 fecha condicion2 punto
    condicion1 fecha condicion 2 transferencia
    condicion 1 fecha condicion 2 pago movil
    condicion 1 fecha condicion 2 efectivo…..
    y uno que me falto condicion 1 fecha condicion 2 sumas de todos los 4 anteriores.

Deja un comentario

Los campos requeridos estan marcados con *.