Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas con números

Es este ejemplo observemos como contar celdas con números, contar celdas con valores no numéricos, contar celdas con valores positivos y contar celdas con valores negativos, veamos cada caso.

Contar celdas con valores numéricos

Contar celdas con números

En este ejemplo en la celda E3 se usa la fórmula:

=CONTAR(B3:B8)

Para comprender este caso notemos que en el caso de CONTAR se cuentan solo los las celdas cuyo contenido sea un número, notemos que si bien aparentemente el resultado debería ser 2 ( por los valores 100 y 20 en dos de las celdas, el resultado en realidad es 3, y eso se produce por que una de las celdas contiene una fecha, y para Excel las fechas son consideradas (y manipuladas) como números.

Contar celdas con valores no numéricos

En mismo ejemplo, en la celda E4 se utiliza la fórmula:

=CONTARA(B3:B8)-CONTAR(B3:B8)

En el caso de esta fórmula, la función CONTARA  lo que hace es buscar en las celdas que se encuentren entre B3 y B8, todas las celdas con algún contenido independientemente de lo que contengan, es decir contará todas las celdas que se encuentran en uso, que en el caso del ejemplo es 5, luego de ello se resta el resultado comentado en el párrafo anterior donde CONTAR nos devuelve 3, lo cual nos da como resultado 2, es decir, la cantidad de celdas que contienen caracteres no numéricos es 2.

Contar celdas con números positivos

Contar celdas con números positivos

Para poder resolver este caso emplearemos la función CONTAR.SI, la cual recibe como primer parámetro las celdas sobre las que se evaluará si son contadas o no, mientras que el segundo parámetro es el determina para cada una de las celdas del rango anterior si deben ser contadas o no.

La fórmula empleada en E3 es:

=CONTAR.SI(B3:B8,">0")

El resultado de esta fórmula es 3 debido a que se incluyen las celdas B4, B6 y B8, en caso se requiera incluir dentro de esta relación de celdas a la celda B7 (con cero).  La fórmula tendría que ser:

=CONTAR.SI(B3:B8,">=0")

Contar celdas con números negativos

De forma similar al  caso anterior podemos llegar a determinar el número de celdas que contienen números negativos.

Contar celdas con números negativos

Para el caso de este ejemplo la fórmula empleada es:

=CONTAR.SI(B3:B9,"<0")

En caso se requiere determinar los números menores o iguales que cero, la fórmula a emplearse sería:

=CONTAR.SI(B3:B9,"<=0")

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5