Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas menores a un número

En este ejemplo veremos como contar celdas menores a un número, para ello emplearemos la función CONTAR.SI, examinemos el siguiente ejemplo.

Contar celdas menores a un número

Fórmula para contar celdas menores a un número

En el caso de la celda G4 se usó la fórmula:

=CONTAR.SI(C3:C10,"<2012")

Y en el caso de la celdas G5 se utilizó la fórmula:

=CONTAR.SI(C3:C10,"<=2012")

Como podemos ver en el recuadro izquierdo se tiene una lista simplificada de vehículos con sus respectivos años de fabricación, en G4 se busca identificar cuantos han sido fabricados antes del 2012 (no incluye el 2012) mientras que en el caso de G5 se busca contar la celdas menores o iguales al número 2012 (se incluye el 2012).

Notemos que se puede reemplazar la fórmula por una que haga referencia a otra celda como por ejemplo =CONTAR.SI(C3:C10,"<" & J4) donde la celda J4 debe contener el año con el cual se realizará la comparación, observe que en este caso el símbolo menor que esta siendo unido al contenido de la celda J4 por medio del ampersand (&) el cual sirve para unir (concatenar) ambos contenidos.

Un comentario

  1. Buen día.
    tengo una pequeña base de datos y uso una formula para calcular suma de valores en un rango de fechas determinado para lo cual tengo la siguiente formula: =SUMAR.SI.CONJUNTO(E5:E35,$A$5:$A$35,">="&B2,$A$5:$A$35,"<="&D2)
    Lo que sucede es que tengo en esa columna valores positivos y negativos los cuales se cruzan entre si, o sea, si hay 100 positivos y 20 negativos la formula me arroja como resultado 80, pero así no me sirve, yo necesito sumar únicamente los valores negativos. ¿como puedo hacer?

Deja un comentario

Los campos requeridos estan marcados con *.