Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado
Cálculo cuarta categoria, Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

| 8 comentarios

En general, las User Defined Functions (UDF) o funciones definidas por el usuario, permiten crear funciones personalizadas que incorporando macros, abrevian y simplifican cálculos repetitivos. Podemos disponer de éstas, de manera similar a las funciones definidas en Excel.

A continuación el ejemplo mencionado que se aplica a trabajadores independientes, que reciben una remuneración por su trabajo y entregan recibos por honorarios.

Antes de determinar el monto, se definen deducciones, en este caso del 20% del ingreso bruto (hasta un límite de 24 UIT u S/. 86,400 anuales) y un monto de 7 unidades impositivas tributarias (UIT).

En la hoja de cálculo escribimos el ejemplo de un ingreso bruto anual (IB) de S/. 100,000, al cual queremos calcular el impuesto.

Las celdas D6 y D8 son parámetros (fijos) mientras que la Renta Imponible (RI) ubicada en la celda D10 es una variable a la cual se debe aplicar la tasa (celda D11) que depende a su vez del tramo en el cual se encuentre el ingreso bruto anual. El ejemplo se muestra a continuación:

Dibujo0 300x201, Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

De acuerdo al tramo en el que se encuentre el IB se aplican las siguientes tasas:

1º Hasta 27 UIT ……….15%

2º De 27 a 54 UIT……. 21%

3º Más de 54 UIT…….. 30%

 En el ejemplo, le corresponde el segundo tramo (S/. 100,000 es aproximadamente 27.8 UIT)

Adicionalmente, para elegir la tasa que corresponde a determinado ingreso, es necesario aplicar en la celda D11, la siguiente fórmula:

 =SI(D5<=(27*D7);0.15;SI(D5<=(54*D7);0.21;0.3))

 Luego; ingresamos al Editor de Visual Basic, e insertamos un módulo para poder escribir el siguiente código:

Dibujo11 300x185, Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

(Para una mayor visualización de la imagen, hacer click en la misma)

Se finaliza la edición del código macro, se guarda y salimos del ambiente de programación en VB y retornamos a la hoja electrónica inicial y en la celda D12 (Impuesto a pagar) y se digita               + i (D5) y nos mostrará el resultado.

Dibujo31 300x201, Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

(Para una mayor visualización de la imagen, hacer click en la misma)

La función recientemente creada i(IB) se puede ubicar en funciones Definidas por el usuario, tal como se muestra en la siguiente imagen:

Dibujo41 300x215, Ejemplo de UDF para el Cálculo de Pago de Impuesto a la Renta de Cuarta Categoría

(Para una mayor visualización de la imagen, hacer click en la misma)

Elaborado por: Isabel 

8 comentarios

Deja una respuesta

Los campos requeridos estan marcados con *.