Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar comparando rangos

Veamos como contar comparando rangos, para ello examinemos el siguiente ejemplo donde se exigen dos condiciones, y al menos una de ellas comprende una comparación de rangos.

Contar comparando rangos

Fórmula para contar comparando rangos

En la celda H5 podemos observar la siguiente fórmula:

=SUMAPRODUCTO((B3:B8=G5)*(D3:D8>E3:E8))

Primera condición (B3:B8=G5), en este caso se esta exigiendo que cada una de las celdas del rango B3:B8 sea igual al contenido de la celda G5, sin importar las diferencias por mayúsculas y minúsculas, cada uno de los resultado sera una lista de valores lógicos, VERDADERO si se cumple la igualdad, y FALSO si no se cumple la igualdad. La lista resultante para el rango empleado será:

{FALSO, VERDADERO, FALSO, FALSO,FALSO, VERDADERO}

Segunda condición (D3:D8>E3:E8), para esta condición se comparan los rangos D3:D8  y E3:E8, la comparación se realiza celda por celda en el mismo orden es decir primero se compara D3>E3 luego D4>E4, y así sucesivamente, esto nos generará una segunda lista de valores con VERDADERO y FALSO como resultado de la comparación.  La lista correspondiente al segundo rango será:

{FALSO, FALSO, VERDADERO, FALSO,FALSO, VERDADERO}

Uso del operador “*” este operador mezcla (multiplica)  los resultados de ambas listas, asumiendo “1” en caso se trate de un valor VERDADERO y “0” en caso se trate de un valor FALSO, por lo tanto solo cuando se multiplique 1*1 obtendremos 1, en todos los demás casos (1*0, 0*1, 0*0) el resultado será cero, de acuerdo a estos la multiplicación de ambos rangos nos generará:

{0,0,0,0,0,1}

Finalmente la función SUMAPRODUCTO nos retornará la suma de los valores de esta lista, es por ello que obtenemos 1.

Tengamos presente que el operador “*” solo retornará 1 cuando todos los valores sean verdaderos, es decir que todas las condiciones se cumplan, si se colocar mas condiciones es posible añadiendo un “*”  y entre paréntesis “( )” la condición adicional, en el ejemplos se utilizaron dos expresiones lógicas o condiciones a cumplirse por los rangos involucrados, si se quisiese emplear solo una condición se necesitaría una variación examinada en el artículo contar comparando dos columnas.

Por otro lado si no se requiere realizar una comparación con rangos, sino con valores fijos, la solución es algo mas sencilla por que existe una función para ello, lo cual se revisó en el artículo contar con varias condiciones.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5