Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar comparando dos columnas

Para contar comparando dos columnas emplearemos la función SUMAPRODUCTO, veamos como hacerlo en el siguiente ejemplo.

Contar comparando dos columnas

Fórmula para contar comparando dos columnas

Como podemos observar en la celda G4 se ha empleado la siguiente fórmula:

=SUMAPRODUCTO(--(D3:D7>C3:C7))

La comparación realizada por medio de D3:D7>C3:C7 , lo que realiza es comparar una a una todas las celdas en el mismo orden (primero D3 con C3, luego D3 con C4 y así sucesivamente), esta comparación nos retornará una lista de valores, VERDADERO si la cantidad de Febrero es mayor a la de Enero, y FALSO en caso contrario.

La lista de valores para el ejemplo en que han comparado las dos columnas (Febrero y Enero) son:

{VERDADERO, VERDADERO, VERDADERO, FALSO, FALSO}

Luego de ello el operador  doble guión “–”  lo que hace es cambiar los valores obtenidos, “1” en caso el valor sea VERDADERO, y “0” en caso el valor sea FALSO, la lista que compara las dos columnas quedaría de la siguiente forma:

{1,1,1,0,0}

Finalmente la función SUMAPRODUCTO permite sumar todos los valores obtenidos en esta lista, que en este caso nos resulta 3.

De forma similar, si queremos comparar las dos columnas (Enero y Febrero) a fin de encontrar en cuales el número ha disminuido, nos bastaría con modificar la fórmula para que quede de la siguiente forma:

=SUMAPRODUCTO(--(D3:D7<C3:C7))

Este fórmula es empleada en G5 y nos proporciona 2 como resultado de la operación.

 

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5