Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado
Logo Excel Avanzado

Función WorksheetFunction.IsLogical

| 1 Comment

La función WorsheetFunction.Islogical es una función de VBA que comprueba que comprueba si un valor es un valor lógico (true o false) y devuelve verdadero o falso según sea el caso.

El código mostrado comprueba si un valor es lógico, se aprecia mejor en una compilación paso a paso con F8

El código mostrado comprueba si un valor es lógico, se aprecia mejor en una compilación paso a paso con F8

(Para mayor visualización de la imagen, hacer click en la misma)

El código al interactuar con la interfaz Excel devuelve el resultado en el idioma (en este caso verdadero o falso) en que esta configurada la interfaz Excel.

Para mostrar lo mencionado, ejecutamos el siguiente código con el valor de la celda igual a true

Al momento de interactuar considera el idioma en la cual esta configurado ésta

El código al momento de interactuar considera el idioma en la cual esta configurado ésta

(Para mayor visualización de la imagen, hacer click en la misma)

Ahora compilaremos el mismo código con el valor de la celda igual a verdadero

Compilación con el valor de la celda igual a verdadero

Compilación del código con el valor de la celda igual a verdadero

(Para mayor visualización de la imagen, hacer click en la misma)

Author: Fernando Daniel

Gestor de Proyectos - A&J Instalaciones S.R.L.

One Comment

  1. Necesito de tu ayuda con una macros que tengo que implementar. deseo hacer lo siguiente tengo un libro el cual posee unos datos formulados para que me otorgue un mensaje o un tiempo limite de fecha de respuesta dependiendo de cuando se recibió un reclamo. =SI(ESBLANCO(I3);”Sin Llenar”;SI(I3=”Reconsideración”;C3+DIA(20);C3+50)) al otorgarme la fecha limite de respuesta quiero hacer dos cosas en macros al abrir los libros: 1- que cuando la fecha que resulte de la formulación este comprendida entre HOY Y HOY + 5 DÍAS se coloque en fondo rojo (ojo ya utilice el formato condicional pero no me funciona para utilizar una macro ya que el formato condicional solo ilumina la celda, el fondo se mantiene como “Sin relleno”), y, 2-que al haber una celda en fondo color rojo me arroje un msg box indicándome que la fecha xxx le quedan tantos días para vencerse, ya logre hacer el msg box aunque soy novata aun no he logrado aplicar la función al fondo de los colores, agradecería su colaboración y si podría enviarme un mail para enviarle el ejemplo y lo que tengo hasta ahora…gracias!!!

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5