Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar por grupos en Excel

Por medio de la siguiente fórmula lograremos mostrar como se puede lograr totalizar por grupos, en ejemplo vemos como existen dos grupos o equipos, y se requiere obtener la suma del primer grupo o equipo, y del segundo grupo.

Como podemos observar, la fórmula empleada en  D4 es:

=SI(B4=B3,"",SUMAR.SI(B:B,B4,C:C))

Tengamos en cuenta que es necesario  que la información se encuentre ordenada a fin de que el resultado sea mostrado una sola vez por cada grupo, este se produce por que la función SI esta comparando dos celdas contiguas, y si el elemento es nuevo, entonces se calculará el total, caso contrario se mostrará la celda en blanco.

En la parte interna de la fórmula encontramos a la función SUMAR.SI, esta fórmula recibe tres parámetros, el primero y el segundo corresponden a la condición a cumplir,  en este caso se busca en toda la fila B, y de acuerdo al segundo parámetro solo de toma en cuenta las filas (en la columna B)  en las que aparezca el valor existente en B4, el cual corresponde a “Equipo1”.

Finalmente luego de identificarse las filas en las que aparece “Equipo1”, se emplea el tercer parámetro para determinar los valores a ser tomados en cuenta en la suma, de esta forma los dos primeros parámetros definen que se debe usar las filas  4, 5, 6 y 7, y el tercer parámetro nos ayuda a identificar que las celdas tomadas para la suma deben ser C4, C5, C6 y C7.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5