Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar por años en Excel

En el siguiente ejemplo veremos como realizar una suma por años en Excel, para ello observemos que en el siguiente cuadro tenemos un conjunto de productos que han sido vendidos en diferentes fechas y se necesita identificar por medio de una fórmula el monto total de venta por cada año.

Fórmula para Sumar por años en Excel

En la celda G5 podemos emplear la siguiente fórmula:

=SUMAR.SI.CONJUNTO($D$4:$D$11,$B$4:$B$11,">="&FECHA(F5,1,1),$B$4:$B$11,"<="& FECHA(F5,12,31))

En esta fórmula se emplea la función SUMAR.SI.CONJUNTO, esta fórmula recibe en el primer parámetro el rango de celdas sobre las se aplicaría la suma, y en los siguientes parámetros se reciben las restricciones por medio de pares.

Para efectos de la fórmula mostrada, el segundo y tercer parámetro sirven para restringir la relación de valores a ser empleados a aquellos cuya fecha sea mayor o igual al 01/01 del año que se indique en la celda F5, en este caso se trata del año 2016.

Mientras que el cuarto y quinto parámetros sirven para limitar la relación de valores, a aquellos que sean menores o iguales al 31/12 del año que F5 contenga, en este caso el año 2016.

Notemos que en esta fórmula la función FECHA tiene por finalidad armar una fecha, para lo cual recibe un número de año, un número de mes y el número de día.

 

2 Comments

  1. 05/01/2018 31/03/2018 85 1.020,00 127,50 127,50 1.275,00
    Fecha de Ingreso Fecha de Permanencia en el Hogar Dias de Permanencia en el Hogar Alimenticias Limpieza de Edificios Limpieza Personal TOTAL

  2. Hola estoy interesado en una formula de sustitución pero no se como se podría organizar…

    el planteamiento es el siguiente necesito sustituir las referencias de fabricante por los ID de producto generados por la web
    entonces tenemos unos productos A,B,C… que su despiece es G,T,C,H…
    entonces al subir estos productos a la web y busco relacionarlos me pide que ponga cual es el ID web del producto relacionado, así que al exportar la tabla a csv y ir a editar de forma masiva, necesito revisar código por código a su producto relacionado (osea su despiece)

    Lo que necesitaría es generar 2 tablas una con las referencias y sus ID web y otra los productos con sus despieces, y la formula debería sustituir en el contenido de la tabla las referencias de los despieces por los ID web…

    llevo buscando informacion por todas partes y no localizo la funcion con la que pudiera resolver este dilema… alguna idea?

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5