Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar los N números mas bajos

En este ejemplo veamos como, dentro de un conjunto de datos, identificamos a elementos de menor valor y luego los sumamos.

Para efectos de simplificar el ejemplo tenemos los valores del 100 al 800, para efectos de comprender el ejemplo se están colocando estos valores en orden, sin embargo para la fórmula no es necesario que los valores se encuentren en orden.

La fórmula empleada en E4 es:

=SUMAPRODUCTO(K.ESIMO.MENOR(B4:B11,{1,2,3}))

En esta fórmula, por medio de la función K.ESIMO.MENOR estamos identificando los tres valores mas bajos, esta función retornará una lista de valores en este caso { 100,200,300}  los cuales se pueden sumar por medio de la función SUMAPRODUCTO.

Si necesitásemos los dos valores mas bajos podríamos emplear {1,2} en lugar de {1,2, 3}, si por el contrario se necesitase una lista mas amplia de valores y se desea evitar colocar toda la relación de valores podríamos emplear una fórmula como:

=SUMAPRODUCTO(K.ESIMO.MENOR(B4:B11,FILA(INDIRECTO("1:3"))))

Donde el 1:3 correspondería a los tres números mas bajos, bastaría reemplazar ese 3 por la cantidad de números mas bajos que se deseen considerar.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5