Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Sumar con condiciones en Excel

Existen dos formas en las sencillas en las que se puede sumar con condiciones en Excel, veamos el siguiente ejemplo para  ver como resolverlo.

Como se puede ver en el cuadro tenemos una relación de vendedores y los montos de venta de cada uno de ellos, se busca sumar estos montos por vendedor.

Sumar con condiciones en Excel, Solución 1

En la celda F4 se ha empleado la siguiente fórmula:

=SUMAR.SI($B$4:$B$11,E4,$C$4:$C$11)

Aquí la función SUMAR.SI presente realizar la suma solo en los casos en los que se cumpla una condición, los dos primeros parámetros sirven para definir la condición a cumplirse, en este caso se busca que el rango de celdas entre B4 y B11 correspondan al vendedor indicado en la celda E4 (“Mario”), esto permite determinar cuales son las filas que deben ser consideradas o no al momento de la suma, luego de ello, el tercer parámetro (en rango de celda de C4 a C11) contiene las celdas que se tomarán en el momento de realizar la suma, no todas estas celdas son usadas, solo se toman las celdas que cumplan con las condiciones del especificadas en los dos primeros parámetros.

Sumar con condiciones en Excel, Solución 2

En el caso de la celda E11 se ha empleado la fórmula:

=BDSUMA(B3:C11,2,E9:E10)

En este caso, en el primer parámetro se recibe la base de datos sobre la que se considerará la suma a realizarse, el segundo parámetro indica la columna relativa a la base de datos que contiene los datos a ser sumados, la columna 1 corresponde en este caso al “Vendedor” y la columna 2 corresponde al “Monto”, como los datos a ser sumados están en las columna del “Monto” se deberá emplear 2 en el segundo parámetro.

Finalmente el tercer parámetro contiene las condiciones a cumplirse para considerar si se debe realizar el conteo o no, en este caso se busca solo aquellos que en la base de datos el campo “Vendedor” corresponda a “Mario”.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5