Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Número de celdas sin errores

Para contar el número de celdas sin errores, en el siguiente ejemplo utilizaremos las funciones ESERROR, NO y SUMAPRODUCTO, veamos como emplearlas:

Número de celdas sin errores

Fórmula para hallar número de celdas sin errores

Como podemos observar en la celda E3, esta contiene la fórmula:

=SUMAPRODUCTO(--NO(ESERROR(B3:B10)))

En esta fórmula la función ESERROR evalúa cada una de las celdas que recibe como parámetro, retornando VERDADERO si la celda contiene un error, y FALSO en caso contrario, luego la función NO invierte estos valores, cambiando los valores VERDADERO por FALSO y viceversa.

Luego de ello tenemos el operador  “–”   (doble guión) el cual convierte los valores VERDADERO en “1” y los valores FALSO en “0”, para finalmente todos los “1” que se hayan obtenido sean sumados por medio de la función SUMAPRODUCTO.

Si por el contrario no se requiriese el número de celdas sin errores sino la cantidad e celdas con error la fórmula para este ejemplo sería:

=SUMAPRODUCTO(--(ESERROR(B3:B10)))

En esta fórmula (respecto de la anterior) solo se ha omitido el uso de NO a fin de poder contar las celdas sin errores.

Cabe precisar que esta última fórmula fue analizada con detenimiento en el artículo “Contar celdas con error

 

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5