Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar Pares e Impares

Veamos en el siguiente ejemplo varias alternativas para contar pares e impares en Excel, para poder este ejercicio vamos a usar funciones como ES.PAR, ES.IMPAR, y RESIDUO.

Contar pares e impares

Fórmula para contar números impares

En este caso en celda E3 hemos empleado la fórmula:

=SUMAPRODUCTO(--(RESIDUO(B3:B9,2)=1))

Comencemos revisando RESIDUO(B3:B9,2) , lo que hace esta función es dividir cada una de las celdas que se encuentran en el rango B3:B9  entre 2, y obtener el residuo correspondiente, el cual podría ser “uno” o “cero”,  será “1” si el número es impar y “0” si el número es impar.

De esta forma para efectos del ejemplo, mostrado la lista de resultados para celda será: {1, 1, 0,1,0,0,0}

Luego la fórmula realiza una comparación con el número 1, RESIDUO(B3:B9,2)=1, con ello cada uno de los valores es convertido a VERDADERO y FALSO, VERDADERO si el resultado anterior es uno (se trata de un número impar) y FALSO en caso contrario (se trata de un número par) , la lista de valores ahora será:

{VERDADERO, VERDADERO, FALSO, VERDADERO, FALSO, FALSO, FALSO}

Luego de aplicar el operador “–“, estos valores se convertirán en {1, 1, 0,1,0,0,0}

Finalmente la función SUMAPRODUCTO sumará cada uno de los valores empleados obteniéndose 3.

Ahora bien para efectos solo de este ejemplo la fórmula puede simplificarse de la siguiente forma:

=SUMAPRODUCTO((RESIDUO(B3:B9,2)))

Sin embargo esta simplificación no se podría aplicar para los múltiplos (o no) de otros números, ni para contar contar números pares.

 

Fórmula para contar números pares

De acuerdo a lo examinado en el caso anterior podemos cambiar la comparación del residuo por cero (en lugar de uno) y la fórmula quedaría de la siguiente forma:

=SUMAPRODUCTO(--(RESIDUO(B3:B9,2)=0))

Con ello el residuo obtendrá VERDADERO cuando la operación no tenga residuo (sea par), y con el operador “–” estos VERDADERO se convertirán en 1, y finalmente SUMAPRODUCTO sumará el “1”   que se ha obtenido por cada par existente.

Cabe precisar que esta fórmula puede requerir restar la cantidad de celdas en blanco ( en caso estas existan) por lo que la fórmula sería:

=SUMAPRODUCTO((RESIDUO(B3:B9,2))) - CONTAR.BLANCO(B3:B9)

Una alternativa es contar las celdas en uso y restar las celdas con números impares obtenidos previamente.

=CONTARA(B3:B9)-SUMAPRODUCTO(--(RESIDUO(B3:B9,2)=1))

Diferenciar números pares e impares

En los casos anteriores se observó como contar todos los pares e impares de un rango de celdas (todo con una sola fórmula), en este caso se asumirá que de podrá disponer de un paso previo para determinar si cada celda es par o impar, para el ejemplo anterior evaluaremos si la celda B3 es par o impar.

Si no existiesen celdas en blanco las fórmulas para determinar pares e impares son:

Par: =SI(ES.IMPAR(B3), 1, 0)

Esta fórmula retornaría 1 si la celda evaluada es impar, y cero si la celda evaluada es par.

Impar:  =SI(ES.PAR(B3), 1, 0)

Esta fórmula retornaría 1 si la celda evaluada es par, y cero si la celda evaluada es impar.

En caso existan celdas en blanco será necesario modificar la fórmula para identificar a los números pares por:

Par: =SI(Y(ES.PAR(B3),NO(ESBLANCO((B3)))), 1, 0)

Esto se produce por que la función ES.PAR aplicada sobre una celda en blanco devuelve el valor VERDADERO.

 

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5