Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar las veces que aparece un valor

Para contar el número de veces que se repite un dato en Excel, o contar la cantidad de repeticiones de un valor en una lista de valores se pueden emplear la función SI en combinación con la función CONTAR.SI, veamos en el siguiente ejemplo como se puede resolver este caso.

Si nos fijamos en el nombre “Juan”, este valor aparece tres veces, la primera vez ocurre en la celda B3, luego en la celda B7 y finalmente en la celda B11, el objetivos de la fórmula a crearse es lograr que de la misma este número correspondiente a las veces que vienen apareciendo un valor, se puede aplicar para todos los elementos.

Para  contar el número de veces que aparece “Juan” emplearemos la siguiente fórmula en la celda C3:

=SI(B3="Juan",CONTAR.SI($B$3:B3,"Juan"),"")

Esta fórmula ejecutará la función CONTAR.SI solo si la celda a examinar contiene el valor “Juan”, y mostrará la celda en blanco en caso contrario.

Notemos que la función CONTAR.SI solo tiene fijado el inicio del rango B3 (con el $ se convirtió en una celda absoluta), de forma que al arrastrar el valor de C3 hacia las demás celdas, obtendremos por ejemplo en C4 la siguiente fórmula:

=SI(B4="Juan",CONTAR.SI($B$3:B4,"Juan"),"")

De esta forma la fórmula en C4, la parte correspondiente a CONTAR.SI intenta contar el número de veces que aparece el valor “Juan” en el rango de celda B3:B4.

Si queremos que la misma fórmula se use para todos los elementos, podemos emplear de forma similar al ejemplo anterior:

=SI(B3=B3,CONTAR.SI($B$3:B3,B3),"")

o sino, simplificar la fórmula para que solo se use la función CONTAR.SI

=CONTAR.SI($B$3:B3,B3)

Al tener fijo el inicio del rango, en la siguiente celda se tendría algo como:

=CONTAR.SI($B$3:B4,B4)

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5