Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas repetidas

Para contar las celdas repetidas usaremos en este ejemplo la función CONTAR.SI y la función SUMAPRODUCTO, veamos como funciona la siguiente fórmula para poder lograrlo.

contar celdas repetidas

Fórmula para contar celdas repetidas

=SUMAPRODUCTO(CONTAR.SI(D3:D5,B3:B10))

de forma alternativa se puede usar

=SUMAPRODUCTO(CONTAR.SI(B3:B10,D3:D5))

En este ejemplo el rango D3:D5  representa la relación de celdas a ser buscadas,  si se busca las repeticiones de una sola celda (digamos D3) , entonces la parte correspondiente a CONTAR.SI sería CONTAR.SI(D3,B3:B10) o CONTAR.SI(B3:B10, D3)

Analicemos la parte correspondiente a CONTAR.SI, en el caso de CONTAR.SI(B3:B10, D3) lo que se busca es identificar cuantas de las celdas de B3:B10 contienen la celda D3, en este ejemplo las celdas repetidas son B5 y B7 , por lo que el resultado mostraría 2, al   usar CONTAR.SI(B3:B10, D3:D5)  se compara cada una de las celdas de D3 a D5 en el rango B3:B10, el primer resultado sería 2 ( por las celdas repetidas B5 y B7), el segundo resultado sería 1 (por que D4 se repite en B4) y el tercer resultado sería 2 (por que D5 se repite en B3 y B10), es decir obtendríamos los valores {2,1,2} .

Finalmente la función sumaproducto multiplica cada uno de los valores por la unidad, y suma el resultado, es decir suma 2 + 1 + 2, lo cual nos da que el total de celdas repetidas es 5.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5