Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas que terminan en un texto

En este ejemplo observaremos como contar las celdas que terminan en un texto, ya sea un caracter, o un conjunto de caracteres, o mediante alguna condición especial, veamos el ejemplo:

Contar celdas que terminan en un texto

Fórmula para contar celdas que terminan en un texto

En el primer caso observamos que se empleó la fórmula:

=CONTAR.SI(B3:B10,"*O")

Notemos que no se distingue entre mayúsculas y minúsculas por lo que tanto la celda B7  y B9 son consideradas, por lo que la cantidad de celdas que terminan en “o” son 2.

De forma similar sucede con el segundo caso, donde se emplea la fórmula

=CONTAR.SI(B3:B10,"*DE")

Notemos que el asterisco representa la existencia de cero, uno o más caracteres, en este caso solo se toma en cuenta la celda B4 , por que su texto finaliza en “de””, es por ello que el resultado es uno.

Finalmente en E5 se usa:

=CONTAR.SI(B3:B10,"*-?")

Esta fórmula además del uso del asterisco se añade el uso de “?” , el cual representa el uso de solo 1 caracter, por lo que en este caso la fórmula estará buscando los textos que comiencen con cualquier cantidad de caracteres, y al finalizar tengan un guión seguido de solo un caracter, que B5 cumple con la condición y que B6 no cumple con la condición ya que tiene dos caracteres luego del guión, y por tanto al contar las celdas cuyo texto terminan con esta condición se obtiene 1.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5