Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas que comienzan por

Para contar las celdas que comienzan por algún texto en particular usaremos la función CONTAR.SI , veamos en el siguiente ejemplo como realizarlo.

Contar celdas que comienzan por

Fórmula para contar celdas que comienzan por

En el ejemplo mostrado podemos observar que la celda E5 contiene la fórmula:

=CONTAR.SI(B3:B11,"ABC*")

Observemos que en esta fórmula, el resultado es 4 por que en el rango de celdas B3:B11  las celdas B3, B4, B5 y B6 comienzan con ABC.

La Fórmula CONTAR.SI examina las celdas  B3:B11, busca de aquellas que cumplan la condición que se definió en el segundo parámetro como “ABC*”, el uso del asterisco al lado derecho del texto  “ABC” equivale a señalar que la celda comienza con “ABC” y es acompañada por cero, uno o más caracteres, sin importar el caracter que se encuentre a continuación.

Notemos que la función CONTAR.SI en la fórmula empleada, no distingue entre mayúsculas y minúsculas, es por ello que en la celda E6 donde se encuentra la fórmula  =CONTAR.SI(B3:B11,"XYZ*")  nos devuelve como resultado 3  a pesar que ninguno de los textos comienza con “XYZ” sino con “Xyz”

 

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5