Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas considerando mayúsculas y minúsculas

Para poder contar las celdas considerando las mayúsculas y minúsculas será necesario emplear las funciones IGUAL en combinación con la función SUMAPRODUCTO, veamos en el siguiente ejemplo como se procederá.

Contar celdas considerando mayúsculas y minúsculas

 

Fórmula para contar celdas sensibles a mayúsculas

Podemos observar que en la celda E3 se esta empleando la fórmula:

=SUMAPRODUCTO(--IGUAL(D3,$B$3:$B$10))

Esta celda nos muestra el valor 2 debido a que solo las celdas B3 y B6 son exactamente iguales a la celda D3.

Para poder contar las celdas comencemos analizando la función IGUAL, esta función realiza la comparación entre el valor de D3 con el rango de celdas empleado, devolviendo VERDADERO  si los valores coinciden, y FALSO  si existe alguna diferencia entre ambos valores, para efectos del ejemplo al estar comparando un valor con una lista de valores, lo que se obtendrá es una lista de valores (de VERDADERO y FALSO).

Para el caso de E3, la función IGUAL devuelve los valores { VERDADERO, FALSO, FALSO, VERDADERO, FALSO, FALSO, FALSO, FALSO} , este resultado es cambiado en la fórmula por medio de los dos guiones (–) , el propósito de los dos guiones es cambiar los VERDADERO en 1, y los FALSO en 0, de esta forma al realizar el intercambio de los valores lógicos por los valores 0 y 1 se podrá proceder a operar los mismos.

Finalmente, para poder contar las celdas considerando las mayúsculas y minúsculas, con la lista de valores ya convertida en {1,0,0,1,0,0,0} en el paso anterior, en la fórmula se procede a emplear la función SUMAPRODUCTO, esta función al recibir como parámetro solo un arreglo, multiplica cada uno de estos valores por la unidad para luego sumarlos, es decir convierte el  {1,0,0,1,0,0,0} en  1 + 0 + 0 + 1 + 0 + 0 + 0 , lo cual nos da como resultado 2.

Contar celdas con CONTAR.SI

En el caso anterior podríamos plantearnos usar una fórmula con CONTAR.SI, la cual sería:

=CONTAR.SI(B3:B10,D3)

La desventaja de emplear esta fórmula es que al no distinguir mayúsculas y minúsculas, la fórmula indicada devolverá 8, es decir todos los valores del rango empleado formarán parte del conteo.

Contar celdas usando la función SUMA

En la fórmula original podríamos plantearnos reemplazar el uso de la función SUMA por la función SUMAPRODUCTO, por lo que la fórmula sería:

=SUMA(--IGUAL(D3,$B$3:$B$10))

Sin embargo para que esta fórmula pueda funcionar y nos muestre el valor correcto, será necesario que al finalizar la edición de la fórmula  (estando dentro de la celda) , se utilice CRTL + SHIFT +  ENTER, a fin de que se pueda realizar el cálculo, luego de ello aparecería de forma automática unas llaves rodeando la fórmula, la fórmula para contar distinguiendo mayúsculas y minúsculas quedaría de la siguiente forma

{=SUMA(--IGUAL(D3,$B$3:$B$10))}

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5