Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas con N caracteres

El objetivo de este ejercicio es llegar a contar las celdas con N caracteres, es decir en el siguiente conjunto de datos se buscará y contará solo aquellas celdas que posean la cantidad de celdas que definamos, veamos como funciona:

Contar celdas con N caracteres

Fórmula para contar celdas con N caracteres

En la celda F3 podemos observar que la fórmula empleada es la siguiente:

=CONTAR.SI(B3:B10,"?????")

Como podemos observar, la Función CONTAR.SI tiene dos parámetros, el primero corresponde al conjunto de celdas que se analizarán, mientras que el segundo parámetro corresponde a la condición que cada una de las celdas definidas en el rango anterior deben cumplir a fin de poder ser contadas, en este caso el signo de interrogación  “?” representa a un caracter (cualquier caracter), de esta forma para exigir que se cuenten solo celdas con 5 caracteres podemos emplear 5 símbolos de interrogación seguidos “?????”, para 7 caracteres (como en la celda F4) podemos emplear “???????”.

Si bien esta forma de repetir los símbolos de interrogación puede ser sencilla para un número bajo de caracteres, cuando se trata de un número alto podemos ayudarnos de la función REPETIR, con lo cual la fórmula quedaría de la siguiente manera:

=CONTAR.SI(B3:B10,REPETIR("?",20))

En este cambio el número 20, significa que el símbolo “?” aparecería 20 veces seguidas debido a la función REPETIR, y por lo tanto la función CONTAR.SI contaría solo las celdas con 20 caracteres.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5