Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Contar celdas con error

En el siguiente ejemplo veremos como proceder a contar las celdas que poseen un error, esta fórmula  se aplicará a todas las celdas que pertenecen al rango B4:B11, veamos.

Contar celdas con error

Fórmula para contar celdas con error

En la celda E4 encontramos la fórmula:

=SUMAPRODUCTO(--(ESERROR(B4:B11)))

Como podemos ver en el ejemplo la celda B6 contiene un error de división por cero, y la celda B9 se esta empleando el nombre de una función inexistente, para conocer un poco mas sobre otros tipos de errores puede revisar Tipos de errores en Excel , estas dos celdas son las que tienen que provocar que la fórmula para contar los errores nos entregue el valor2.

Fórmula ESERROR(B4:B11) 

Esta parte de la fórmula lo que hace es entregarnos no un valor, sino una lista de valores, VERDADERO cuando se encuentra un error y FALSO en caso contrario, en el ejemplo mostrado, la lista de valores sería:

{ FALSO, FALSO, VERDADERO, FALSO, FALSO, VERDADERO, FALSO, FALSO}

Fórmula –(ESERROR(B4:B11) ) 

El operador “–” aplicado sobre el resultado anterior, cambiará cada uno de los valores encontrados por ceros y unos, cero en el caso que el valor sea FALSO, y uno en el caso que el valor sea VERDADERO, de estas forma, con los valores que se obtengan se podrá determinar la cantidad de celdas con error.

La lista quedaría de la siguiente forma: { 0,0,1,0,0,1,0,0}

Fórmula SUMAPRODUCTO

Con el resultado anterior ({ 0,0,1,0,0,1,0,0} ) solo nos resta sumar  los valores obtenidos a fin de llegar a determinar la cantidad de celdas con error, ello es posible por medio de la función SUMAPRODUCTO, esta función sumará todos estos valores  ( 0 + 0 + 1 + 0+ 0 + 1 + 0 + 0 ) de esta forma obtendremos 2 como resultado.

Alternativa para contar celdas con error

De forma alternativa podemos emplear la fórmula:

=SUMA(--(ESERROR(B4:B11)))

Sin embargo, para que esta fórmula funcione al final la edición (mientras nos encontremos dentro de la celda) debemos presionar la combinación de teclas CRTL + SHIFT  + ENTER , con lo cual la función SUMA podrá realizar la suma de la lista de valores, luego de presionar esta combinación de teclas la fórmula aparecerá en la celda con la siguiente forma:

{=SUMA(--(ESERROR(B4:B11))) }

Esta fórmula nos entregará el mismo resultado, que de acuerdo al ejemplo mostrado sería 2.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5