Excel Avanzado

Macros, Vba en Excel y muchos ejemplos de nuestro Curso de Excel Avanzado

Excel Avanzado

Buscar valores repetidos en Excel

En este ejemplo veremos como buscar valores repetidos en Excel, para lo cual emplearemos dos listas de valores, una lista con todos los valores existentes, y una segunda lista desde la que se comprobará uno a uno si todos los elementos se encuentran en la otra lista, veamos.

Buscar valores repetidos en Excel

Fórmula para buscar valores repetidos en Excel

La “Lista1” contiene la base de datos donde se realizará la búsqueda mientras que la “Lista2” contiene la lista de valores a ser buscados, se trata de determinar si cada uno de los valores de esta “Lista” aparece en la “Lista1”.

Para ello, en la celda E3 podemos encontrar la fórmula:

=SI(ESERROR(BUSCARV(D3,$B$3:$B$7,1,FALSO)),0,1)

De esta forma la función BUSCARV lo que esta realizado es buscar el valor que contiene la celda D3 (“Juan”) dentro del rango B3:B7, el tercer parámetro (1) indica que si se encuentra el valor buscado se retorne el valor que se encuentra en la primera columna de la base de datos, y finalmente el último parámetro “FALSO” provoca que se realice una búsqueda exacta del valor D3.

Si la función BUSCARV no encuentra el valor buscado, entonces devolverá el error #N/A, este valor no puede formar parte de una operación matemática, por ello se introduce el uso de la función ESERROR, el cual evalúa si lo recibido es un error o no, es decir, si se obtiene #N/A, al función ESERROR retornará VERDADERO, en todos los demás casos se devolverá el valor FALSO.

Finalmente la función SI convertirá los valores VERDADERO en cero y FALSO en uno, es decir si el valor buscado existe se obtendrá el nombre buscado, ESERROR lo convertirá en FALSO, y la función SI lo convertirá en 1, caso contrario si el valor no existe se obtendrá 0.

Contar valores repetidos en Excel

El caso anterior es conveniente cuando necesitamos distinguir uno a uno si los valores empleados existen en la otra lista, en caso no se requiera esto y solo se necesite identificar la cantidad completa de valores de la “Lista2” que aparecen en la “Lista1”, podemos añadir simplemente una sumatoria sobre lo obtenido con la fórmula anterior.

O bien emplear la siguiente fórmula:

=SUMAPRODUCTO(CONTAR.SI(B3:B7,D3:D5))

Esta fórmula fue revisada con detenimiento en el artículo contar celdas repetidas.

Tomemos en cuenta que en caso utilicemos una sumatoria estaremos obteniendo “Cantidad de elementos de la lista 2 que aparecen en la lista 1 “, mientras que al emplear esta última fórmula estaremos obteniendo “Cantidad de veces que los elementos de la lista 2 aparecen en la lista 1”.

One Comment

  1. Hola muy buena tarde, estoy buscando la formula para relacionar una sumatoria con una celda que determine agregarlo a la suma; ejemplo:
    Suma $$$ CONCEPTO Pagado o Pendiente.
    =SUMA(L2:L33)-CONTAR.SI(Q2:Q33,”PAGADO”)

    Sin mas por el momento, quedo a sus ordenes.

Deja un comentario

Required fields are marked *.


Excel Avanzado located at , Lima, Perú . Reviewed by usuarios rated: 4.7 / 5